Resolved: Delayed analytics data following AWS and Databricks incidents in us-east-1

Incident Report for CipherOwl - System

Resolved

Summary
Earlier today, AWS experienced a service incident in the us-east-1 region beginning at approximately 2026-05-07 23:59 UTC, which subsequently affected Databricks (incident ES-1903956) and caused brief delays in some of our analytics data pipelines.

Our core services (risk screening, address metadata, and the CipherOwl API) remained available throughout the event. All affected internal pipelines have since recovered.

Customer impact (now resolved)
- During the incident, some dashboards and analytics views may have shown data older than usual.
- Newly ingested blockchain activity may have taken longer than normal to appear in reports.
- Real-time screening, scoring, and API lookups were not affected.

Current status
All CipherOwl systems have recovered and are operating normally. We are continuing to closely monitor the upstream AWS and Databricks status pages until both providers mark their incidents fully resolved, and will post an update if anything changes.

No customer action is required.
Posted May 08, 2026 - 00:00 UTC